Voiceover parle en anglais sur certaines pages Web

Accueil Forums macOS Voiceover parle en anglais sur certaines pages Web

Clément
Participant

Bonjour à tous.

Je sais que ce problème est arrivé à tout bons utilisateurs de Voiceover sur Mac qui se respectent.
Sur certaines pages Web mal balisées, VoiceOver se met subitement a dire des phrases en français avec une voix anglophone, en l’occurrence Alex pour moi. Chose encore plus agaçante: le débit habituel de la voix est réglée à 75% chez moi. Mais Alex a l’air de parler d’eux fois plus vite, et même si avec l’habitude nous arrivons à comprendre nos synthèses vocales à des vitesses trop rapide pour le commun des mortels 😂, il y a quand même une limite, surtout quand c’est une voix anglaise qui s’efforce de perfectionner son français.
Par conséquent, Y’a -t-il des solutions permettant de contourner ce souci. Il y a bien le réglage de la détection automatique des Lang que l’on peut désactiver dans iOS, mais à ma connaissance il n’existe pas sur Mac.

Je vous remercie d’avance pour vos réponses.
Cordialement

Powergeek31
Participant

Bonjour Clément.
Personnellement, je ne connais pas de solution réellement efficace à ce problème. Moi aussi, je me fais régulièrement avoir, que ce soit sur iPhone ou sur Mac. Même mon Windows avec Google chrome me fait le coup.
Pour l’iPhone, j’ai trouvé la parade.
Il suffit d’inclure le français dans son rotor des langues, et de le cocher. Mais du coup, je ne sais pas si cette option existe sur Mac.
Si c’est le cas, tu peux te dépatouiller avec ça. Sinon, franchement désolé.
Bonne journée à toi, Et bon courage.
Tu vas devoir être un professeur patient pour apprendre à un Mac anglophone à parler français. Ces ordinateurs ont une très nette tendance à être un peu dur du micro, Et en plus, ils n’écoutent rien. Caractériels, en plus.. Lol.

Clément
Participant

Salut Powergeek.

Effectivement, je joue avec le rotor de langue d’iOS pour éviter ce souci, mais je crois bien que cela n’est pas de la partie sur Mac. Après, on peut toujours faire avec, mais il faudrait de plus en plus qu’Apple, et également les sites, se penchent là-dessus.
J’avais également pensé à supprimer toutes les voix anglophones de la machine, mais pas sur que l’on puisse toutes les désinstaller et ce n’est pas une chose que j’ai envie de faire. A voir donc s’il y a matière à s’en sortir, 🤣.

Bonne nuit!

Assaad
Participant

Bonjour Clément,
En effet, ce problème a tendance à agacé tout les utilisateurs de Voice Over sur Mac-OS moi y compris,
Pour contourner le problème… j’ai fait comme avec iOS, une voix pour chaque langue, le français aussi, il me reste qu’a jongler avec le menu rapide du Voice Over avec les raccourci : VO+MAJ+flèche droite et gauche pour changer de réglage (voix / volume / débit…) et haut bas pour manipuler le réglage en question, tout comme NVDA sur windows,
Dans ton cas focalise toi sur la voix et choisi le français au lieu de la sélection automatique et le tour est joué, et n’oublie pas de remettre le réglage à son choix par d’origine après avoir terminé avec la page mal balisé,
PS: un conseil : réfléchi à la possibilité de changer la commande VO par défaut vers la touche majuscule pour améliorer l’ergonomie de Voice Over avec ce genre de raccourci quadra-touches,
Passe une belle journée et à plus 😁

Clément
Participant

Salut Assaad.

Franchement, merci pour le tuyau. J’avoue que j’ignorais ce réglage de sélection automatique. Par contre, pour avoir utiliser ce racourcis clavier plus d’une fois, il me semble qu’il faut ajouter la touche CMD aux touches VO + majuscule et les flèches.

Pour ce type de commande un peu complexe, j’utilise souvent verrouillage majuscule plutôt que CTRL option. Mais si tu me dis qu’il y a moyen de changer la commande pour la rendre plus simple, je veux bien l’astuce. Peut-être par l’intermédiaire du commandeur clavier de VoiceOver?

Bonne journée et merci à toi !

Assaad
Participant

Re-bonjour Clément,
Oui c’est ça, désolé j’ai zappé la touche CMD, pour l’ergonomie je crois que je n’ai rien à t’apprendre 😁, tu as déjà appliqué l’astuce en utilisant le verrouillage majuscule au lieu de opt+ctrl, c’est ça ce que je voulais dire,
Sinon pour le commandeur clavier… tu peux l’utiliser pour attribuer des raccourcis à l’ouverture d’une application ou une utilitaire spécifique, par exemple cmd droit+s pour ouvrir safari,
Personnellement je l’utilise à fond le commandeur, ça m’aide à économiser un temps monstre, au lieu de perdre mon temps à chercher dans le dock une application que j’utilise souvent, je lance juste le raccourci et hop, le tour est joué,
Profite bien de ton mac et à plus 😆

Clément
Participant

Je me sers également beaucoup du commandeur clavier et trackpad que je trouve extrêmement efficace. Merci en tout cas pour tes conseils, 😀.

Vous devez être connecté pour répondre à ce sujet.